+31 53 850 6850
EUR
My Account
Cart: 0 item - €0.00
Sideconnect connection kit
€175.00

Availability: In stock

Connection kit for the Sideconnect interface containing ETFE (Ethylene tetrafluoroethylene) capillaries and 5 FFKM (Perlast) perfluoroelastomer ferrules.

Share this product on:

Contains 1.5 meter ETFE (Ethylene tetrafluoroethylene) capillaries (1/16” OD, 0.5 mm ID) and 5 FFKM (Perlast) perfluoroelastomer ferrules. To be used in combination with the Sideconnect interface set, product code 01370 or 01371.

  • Re-usable
  • Excellent chemical resistance to a wide range of chemicals
  • Low friction
Product Code01372
ContentsETFE tubing and 5 FFKM ferrules
Length1.5 m
Outer Diameter (OD)1/16 inch
Inner Diameter (ID)0.5 mm
Material Tube: ETFE (Ethylene tetrafluoroethylene), Ferrules: FFKM (Perlast) perfluoroelastomer
Use in combination withSideconnect interface set 15 mm x 15 mm (01370) and 30 mm x 15 mm (01371)

Write Your Own Review

You're reviewing: Sideconnect connection kit

How do you rate this product? *

 1 star2 stars3 stars4 stars5 stars
Quality

There's no flow in my setup. How do I fix this?

Is your setup clogged with dirt or fully blocked?
Chips can get clogged, for example when they’ve been used before and have not been cleaned the right way. If your chip is clogged with dirt, check our document on the prevention of clogging and/or read the answer to question number one on this page (regarding the cleaning of chips). Clogged chips often do let some flow through the chip, which makes it easier to identify the issue as clogging. If there is no flow at all it’s more likely that the flow path is not connected correctly.

Pinpoint the issue
We recommend walking through the full track of the fluid flows: check if your syringe or pump is not blocked, if your tubing is actually hollow and if your filters let fluids pass through. Then check if your chip has inlet and outlet holes and if these are positioned so that the fluids can go through the chip. The easiest way to do this is to disassemble the setup and check if fluids come out of the pump, then connect the tubing and check if fluids can come through. Keep on adding parts and checking if the fluids go through. This way you can pinpoint the problem.

If the problem remains
If the problem cannot be solved after following the above-mentioned steps, then take some pictures or make a short movie of your setup and send this, together with the description or name of your chip, to Micronit. We will gladly assist you in identifying the issue.